Staking UI Downtime

Incident Report for PoS Mainnet

Postmortem

Issue Summary
Between 14:49 UTC and 16:36 UTC on March 26, 2025, the Polygon Staking UI experienced downtime due to an issue with the RPC endpoint. This caused disruptions in accessing staking-related functionalities.

Root Cause

The RPC endpoint which were being used stopped responding, leading to a failure in retrieving staking data and processing transactions.Resolution

The affected RPC endpoints were replaced, and the Staking UI was restored at 16:36 UTC.

Next Steps

  • Monitoring the system for stability.
  • Evaluating alternative RPC fallback mechanisms to prevent similar issues in the future.

We apologise for any inconvenience caused.

Posted Mar 27, 2025 - 15:29 UTC

Resolved

We are currently investigating this issue.
Posted Mar 26, 2025 - 09:00 UTC